сайт практикующего электронщика-эмбеддера  
Вернуться   сайт практикующего электронщика-эмбеддера > Коммерческие проекты > Управление Webasto Контроллер управления отопителями Webasto > Примеры предпускового включения штатных догревателей.
Регистрация Магазин Коммерческие проекты Открытые проекты

Ответ
 
Опции темы Поиск в этой теме Опции просмотра
  #1  
Старый 04.10.2013, 14:03
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию Пример подключения к VolksWagen Touareg.

. . . Для подключения контроллера к догревателю (7L6 815 071 B, 7L6 815 071 C, 7L6 815 071 G) нужно подключить следующие цепи: в-бус шину, постоянное питание, массу, канал управления. Помпа догревателя и вентилятор климатконтроля включаются автоматически электроникой автомобиля.
. . . Подключение в-бус шины:
Догреватель стоит в задней части переднего левого крыла. Для доступа нужно снять заднюю часть подкрыльника колеса.


. . . Нам нужен 6 пиновый разъём, он крайний на верхней крышке котла. Иногда разъём туго снимается, это связано с попаданием песка в щели между разъёмом и фиксаторами, не давая фиксаторам освободить разъём. Перед снятием разъёма желательно выдуть песок сжатым воздухом. Фиксаторы находятся по бокам разъёма. Для снятия разъёма нужно нажать на фиксаторы, нажать на разъём и потом смыкнуть его вверх.


. . . На фишке видим свободное место 1 пина, туда и нужно вставить клемму с проводом. Желательно иметь родную клемму для разъёма. Провод протягивается через уплотнительную резинку моторного щита, через которую проходит штатный жгут проводов.
. . . Питание контроллера можно взять в любом удобном месте возле блока предохранителей. Я использовал подключение в жгуте диагностического разъёма. Размотав изоленту жгута диагностического разъёма ищем коричневый провод - это масса, красный провод - это постоянный плюс. Питание диагностического разъёма защищено штатным предохранителем.



. . . Контроллер крепится к задней крышке блока предохранителей. Остаётся подключить провод управления контроллером к источнику управляющего сигнала. Если используется сигнализация с обратной связью, можно использовать функцию CallBack для контроля работы предпускового подогрева.

. . . Образ настройки контроллера качаем здесь.
Ответить с цитированием
  #2  
Старый 05.10.2013, 19:21
matrix501 matrix501 вне форума
Новичок
 
Регистрация: 03.10.2013
Сообщений: 8
По умолчанию

Я так понимаю пример настроек (стоит галка "удерживающий сигнал") дан для импульсного типа управляющего сигнала?

если давать с сигналки удерживающий сигнал, то галку "удерживающий сигнал" ставить не надо?

интересует возможность включения/выключения котла через контроллер с кнопки сигналки. Через какой тип сигнала (удерж./импульный) проще реализовать?

сигналка имеет возможность использовать любой тип сигнала
Ответить с цитированием
  #3  
Старый 05.10.2013, 19:47
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Естественно, выбирать тип управляющего сигнала нужно согласно используемого устройства управления. Вообще нужно отталкиваться от конкретной ситуации. Но если есть выбор, то я предпочитаю импульсный сигнал управления. К примеру в таком случае проще реализовать параллельное управление с кнопки. Но на вкус и цвет все фломастеры разные).
Ответить с цитированием
  #4  
Старый 13.10.2013, 21:37
matrix501 matrix501 вне форума
Новичок
 
Регистрация: 03.10.2013
Сообщений: 8
По умолчанию

подскажите, черный провод (канал 1 - обратная связь) имеет выход - или + ?
Ответить с цитированием
  #5  
Старый 13.10.2013, 21:57
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Все выходы имеют отрицательный фронт сигнала, попросту - минусовые.
Ответить с цитированием
  #6  
Старый 15.10.2013, 22:00
matrix501 matrix501 вне форума
Новичок
 
Регистрация: 03.10.2013
Сообщений: 8
По умолчанию

подключил на сигналку, все работает. обратная связь идет на кнопку вызова брелка.
Спасибо за оказанную помощь.

Осталось перепрограммировать клапан 279, чтобы грел двигатель. На данный момент прогревается только салон.
Ответить с цитированием
  #7  
Старый 16.10.2013, 04:43
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
По умолчанию

Можно полюбопытствовать насчёт результата перепрограммирования клапана 279? У меня есть непонятки с Туареговским дизель вебасто 7L6 815 071 D, который Standheizung, а по сему должен быть полноценным пред-пусковым. Что-то мне подсказывает что может понадобиться security access code для изменения некоторых настроек. У кого-нибудь имеется генератор кодов доступа по серийному номеру блока?
Ответить с цитированием
  #8  
Старый 16.10.2013, 08:39
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
По умолчанию

Заходим в блок 18, адаптация 10, затем, по моим данным надо ввести цифру 2 в канал адаптации 09, (0 - значение по умолчанию, 2 - парковочный отопитель) может стать доступным для пользователя через меню авто. Канал 04 - мониторинг клапана 279, по умолчанию стоит 1, можно ввести ноль и удалить его совсем, говорят помогает с прогревом движка и салона одновременно. На некоторых Туарегах этот клапан не стоит и выдаётся ошибка, если ввести 0, то ошибка пропадает и всё становится комильфо.
Ответить с цитированием
  #9  
Старый 16.10.2013, 18:30
matrix501 matrix501 вне форума
Новичок
 
Регистрация: 03.10.2013
Сообщений: 8
По умолчанию

Цитата:
Сообщение от Alex Handy Посмотреть сообщение
Можно полюбопытствовать насчёт результата перепрограммирования клапана 279?
жду пока придет ваг ком, чтобы залезть в мозги.

вот тут тема (http://www.touareg-club.net/forum/sh...ad.php?t=55096), в которой никаких проблем не возникло, человек наоборот поменял 0 на 1, до этого грелся только салон
Ответить с цитированием
  #10  
Старый 16.10.2013, 20:59
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
По умолчанию

Цитата:
Сообщение от matrix501 Посмотреть сообщение
жду пока придет ваг ком, чтобы залезть в мозги.

вот тут тема (http://www.touareg-club.net/forum/sh...ad.php?t=55096), в которой никаких проблем не возникло, человек наоборот поменял 0 на 1, до этого грелся только салон
Спасибо за ссылку, но похоже автор опуса не совсем уверен какую "единичку" и в каком разряде он поменял. Тема требует изучения...
Ответить с цитированием
  #11  
Старый 23.10.2013, 23:05
matrix501 matrix501 вне форума
Новичок
 
Регистрация: 03.10.2013
Сообщений: 8
По умолчанию

да вроде все понятно насчет где что он поменял. Я у него уточнял. Кодировка была 0000000, стала 0000100.

Ваг ком пришел, я поменял кодировку, но пока не проверял прогрев двигателя, т.к. двиг был горячий.

Котел у меня такой же как у него (7L6 815 071 G)
Ответить с цитированием
  #12  
Старый 24.10.2013, 09:00
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
По умолчанию

Цитата:
Сообщение от Admin Посмотреть сообщение
. . . Для подключения контроллера к догревателю (7L6 815 071 B, 7L6 815 071 C, 7L6 815 071 G) нужно подключить следующие цепи: в-бус шину, постоянное питание, массу, канал управления. Помпа догревателя и вентилятор климатконтроля включаются автоматически электроникой автомобиля.
Я правильно заметил неточность, 7L6 815 071 D должно быть вместо C? Насколько я понял, последняя буква означает тип топлива.

Последний раз редактировалось Alex Handy; 24.10.2013 в 09:03. Причина: дополнение
Ответить с цитированием
  #13  
Старый 26.10.2013, 22:50
matrix501 matrix501 вне форума
Новичок
 
Регистрация: 03.10.2013
Сообщений: 8
По умолчанию

греет двигатель и салон, кодировка 0000100
Ответить с цитированием
  #14  
Старый 30.10.2013, 21:39
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
Восклицание Прошу помощи!!

Установил контроллер на touareg 2003г. 2,5tdi, догреватель TT C. желтый и оранжевый провода на питание с диагностического разъема, красный к 1pin на колодке котла, на синий канал с сигналки. В настройках пробовал котлы TT C и TT C\Z, импульсный и удерживаемый сигналы, пробовал просто на синий провод массу подать, котел не запускается, диод не мигает. Замерил тестером провод с 1pin колодки котла идет +12v. При подключении к компу диод мигает зеленым. Как догреватель котел работает, ошибок нет. Может нужно к котлу ещё и CAN от контроллера подвести?
Ответить с цитированием
  #15  
Старый 30.10.2013, 23:58
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Проверьте питание на контроллер, возможно обрыв провода. Светодиод в любом случае должен мигать зелёным после включения. CAN в вашем случае не подключается.
Ответить с цитированием
  #16  
Старый 31.10.2013, 08:42
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
Вопрос Котёл туарега 2006 7L6 815 071D

Всем привет и доброго времени суток.
Хочу разобраться в следующей ситуации:
Купил котёл с Туарега дизель. Хотел подключить к нему диагностику по W-bus посредством универсального адаптера, купленного на E-bay в Белоруссии. Не смог добиться коммуникации с котлом, причём активность W-bus присутствует, осцил. показывает периодические пачки отрицательных коротких импульсов (подтяжка к +12В) Адаптер пытается запустить протокол, но безуспешно, ничего не происходит. Питание пробовал от батареи и от мощного источника +14В. К котлу не подключены: 1. Клапан 279, 2. Водяной насос, 3. Топливный насос. Всё остальное выглядит нормально, могу выложить фотки "мозгов".
Использовал WTT 2.14, который пришёл вместе с адаптером.
Подозреваю что этот котёл имеет модифицированный W-bus и будет работать только с определёнными устройствами от VW по W-bus, в остальных случаях нужен гейтвей VW и шина Can.
Что-то я немного заблудился...
Ответить с цитированием
  #17  
Старый 31.10.2013, 10:51
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Котёл с табурега ТТС. Все ТТС с CAN шиной прекрасно дружат с WTT через w-bus 1 пин. Проблема может быть в самой плате управления, посмотрим фотографии.
Ответить с цитированием
  #18  
Старый 31.10.2013, 21:03
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
Вопрос Вебасто с Табуреги




Думаю собака порылась где-то в этих мозгах. Проверяю банальные вещи, типа целостность проводов и надёжность контактов. Пока всё в норме.
Дальше сообщу/покажу что нарыл...

Последний раз редактировалось Alex Handy; 18.11.2013 в 23:45.
Ответить с цитированием
  #19  
Старый 31.10.2013, 23:57
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Если хотите отремонтировать саморучно, рекомендую вооружиться вольтметром и замерять напряжения на пинах стабилизатора (20 выводная микросхема), во время попытки диагностики.
Ответить с цитированием
  #20  
Старый 01.11.2013, 05:47
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
Смех Проблема решена

Спасибо за отклик. Тут случилось следующее:
Всё заработало, но естественно, не смог сбросить интерлок котла. И как следствие не смог провести полную диагностику.
Всё заработало после того как адаптер, а с ним и вебасто, был подключен к лаптоп компу, с такой же виндой ХР. Соединяется моментально и диагностика работает без проблем. Версия WTT 2.14, которую любезно предоставили продавцы девайса из Белоруссии. Запустил USBview и снял скрин в обоих случаях на двух компах. Проверил драйвер, стоит одинаковый. Первый комп базирован на AMD 64, второй на Пень4 мобайл.
Также пробовал спец. версию WTT патченную (той же версии) с данным адаптером не работает в обоих случаях, хотя порты и всё стоит нормально. Эта патченная версия позволяет снимать интерлок и сливать/менять содержимое настроек, хранящихся в EEPROM котла. Такие вот интересные делишки... Теперь попробую заставить патченную версию WTT для работы с данным адаптером. Надо будет связаться с разработчиком...
Ответить с цитированием
  #21  
Старый 01.11.2013, 09:39
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
Хорошо ТЕСТ репорт Вебасто

Ниже привожу тест отчёт вышеупомянутой вебасты.

Diagnosis report WEBASTO
Thermosystems
31.10.13 16:44:27 Webasto Thermo Test 2.14 page 1 of 1
faults on webasto initial
Configuration:
W-Bus version........................................... .......................1.5
Device name.............................................. ....................E1 MAC
Fuel type.............................................. .........................Diesel
Circulating pump in control idle period.........................................0
Heating duration limitation........................................ .............60 [min]
Factor for shortening of ventilation duration...............................1/1
Device identification number............................................ ...09007019A
Dataset identification number............................................ ..09008576C02
HW version........................................... ............................26/3
SW version........................................... .............................29/04
Date of manufacture heater............................................ ......06.03.06
Customer identification number............................................ .3138364C37
Serial number............................................ .......................00055443
Minimum voltage threshold......................................... .........10,51 [V]
Operating data:
---------------
Working hours............................................. ...................19:11 [h:m]
Operating hours............................................. .................81:57 [h:m]
Start count............................................. ........................290
Error:
------
Fault 1................................................. .....Heating unit interlocked
State of fault............................................. .stored, actual
Code.............................................. .............07h
Counter........................................... .............1
Temperature....................................... .........101 [°C]
Operating state............................................. Off state

Любые комментарии приветствуются.
Ответить с цитированием
  #22  
Старый 01.11.2013, 14:42
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Блокировку можно обнулить через адаптации ваг-кома. Единицу в 7 канал.
Ответить с цитированием
  #23  
Старый 01.11.2013, 22:53
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
Радость

Цитата:
Сообщение от Admin Посмотреть сообщение
Блокировку можно обнулить через адаптации ваг-кома. Единицу в 7 канал.
Да, я понимаю, но ещё понадобится gateway VW, которого нету. Вебаста живёт не столе пока... И в ближайшее время прописку менять не собирается. Сейчас буду работать над тем чтобы "прикрутить" к моему диаг. адаптеру от StarEnergy специальный софт, позволяющий считывать Dataset из EEPROM-ки и сбрасывать блокировку без лишних телодвижений.
Сообщу об успехах дополнительно.
Ответить с цитированием
  #24  
Старый 02.11.2013, 23:41
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
Вопрос

Цитата:
Сообщение от Admin Посмотреть сообщение
Проверьте питание на контроллер, возможно обрыв провода. Светодиод в любом случае должен мигать зелёным после включения. CAN в вашем случае не подключается.
А диод должен начать мигать сразу после подачи питания? Пробовал подключить напрямую к акб, не помогло. Диод мигает только при подключении к компьютеру. Может котел запустится только когда температура за бортом опустится до +4? Подскажите способ, чтобы проверить исправность самого контроллера.

Может быть нужно эту деталь:

нужно перепаять сюда?:

Последний раз редактировалось Kent-rzn; 03.11.2013 в 11:14.
Ответить с цитированием
  #25  
Старый 03.11.2013, 12:17
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Резистор на нижней фото правильно запаян. Верхняя сборка не моя, я тестирую перед отправкой все контроллеры.
Ответить с цитированием
  #26  
Старый 03.11.2013, 14:53
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Это контроллер от Аркадия. Значит нужно перепаять резистор на место!

23:05
Перепаял резистор на его место, не помогло, изменений никаких, котел молчит, диод не мигает. Подскажите пожалуйста, как проверить работоспособность контроллера при помощи мультиметра.

Последний раз редактировалось Kent-rzn; 03.11.2013 в 22:05.
Ответить с цитированием
  #27  
Старый 17.11.2013, 13:55
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Схема простая - если подать минус на синий провод, должен открыться верхний справа транзистор.
Ответить с цитированием
  #28  
Старый 17.11.2013, 20:40
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Цитата:
Сообщение от Admin Посмотреть сообщение
Схема простая - если подать минус на синий провод, должен открыться верхний справа транзистор.
Попробовал от бп ПК 12,2V. При подаче питания на ноге транзистора появляется -0,5V. Когда подключаю минус на к синему проводу на ноге появляется -11,3V.


Я правильно понял какой именно транзистор?
Ответить с цитированием
  #29  
Старый 17.11.2013, 22:33
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Да, это тот транзистор. На правой ножке 12 вольт постоянное, на средней 12 вольт, когда на синем проводе минус. Левая ножка управление, 12 вольт в спячке, 10-11 вольт, когда на синем проводе минус.
Ответить с цитированием
  #30  
Старый 18.11.2013, 18:47
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Значит дело не в контроллере? А это нормально, если на проводе, который протянут с 1го pin котла, постоянно +12V?
Ответить с цитированием
  #31  
Старый 18.11.2013, 19:10
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Первый пин с котла это шина данных w-bus, на нём должно быть 12 вольт.
Ответить с цитированием
  #32  
Старый 18.11.2013, 19:13
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Завтра буду пробовать ещё, как раз температура упала ниже +4 и котел работает постоянно как догреватель. Если ничего не выйдет, можно будет отправить контроллер вам на проверку?
Ответить с цитированием
  #33  
Старый 18.11.2013, 22:46
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
Лампочка

Я бы пошёл немного дальше и проверил наличие +5 Вольт (с подачей управления (-) на синий провод) на выходе микрухи, стоящей слева от упомянутого транзистора сразу после танталового электролита. На фотке не очень видно что за микра но подозреваю это стабилизатор 5 Вольт.
Надо разобраться где питание потерялось. От ЮСБ приходит и всё работает а от интерфейса как-то нет...
До кучи, я бы ещё пропаял все ноги разъёма интерфейса и прозвонил от проводов кабельной части разъёма до контактных площадок на плате, также не вредно убедиться в отсутствии замыканий между соседними по кабелю проводами. Вообще конечно, по хорошему, хотелось бы видеть разъём другого типа, но это приведёт к неизбежному удорожанию... Типа вот такого:

Последний раз редактировалось Alex Handy; 18.11.2013 в 23:37. Причина: дополнение
Ответить с цитированием
  #34  
Старый 20.11.2013, 22:51
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Alex Handy, спасибо за совет! Провода я первым делом прозвонил до контактных площадок и на предмет замыкания. Все контакты пропаять тоже пробовал, а вот про контакты на микрухе: почти на всех ногах есть +12V или 0 и никак не меняется при подаче " - " на управляющий синий провод.



Пробовал запустить догреватель на незаведенном двигателе с помощью Васи - щелкает реле и через секунд 10 запускается котел с характерным гудением, поработал пару минут и отключил. Значит нужно копать в контроллере. Подскажите что можно еще сделать!
Ответить с цитированием
  #35  
Старый 20.11.2013, 23:58
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Проверьте напряжение на 2 пине микроконтроллера - 0, когда синий провод на массе, и 3 вольта, когда синий провод в воздухе. Ну и питание на всех танталовых конденсаторах, когда синий провод на массе.
Ответить с цитированием
  #36  
Старый 21.11.2013, 00:23
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Я извияюсь, немного поточнее, 2 пин это который?
Ответить с цитированием
  #37  
Старый 21.11.2013, 00:25
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Считать от точки против часовой стрелки. Микроконтроллер, это самая большая микросхема на плате.
Ответить с цитированием
  #38  
Старый 21.11.2013, 06:34
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
Лампочка

Цитата:
Сообщение от Kent-rzn Посмотреть сообщение
Alex Handy, спасибо за совет! Провода я первым делом прозвонил до контактных площадок и на предмет замыкания. Все контакты пропаять тоже пробовал, а вот про контакты на микрухе: почти на всех ногах есть +12V или 0 и никак не меняется при подаче " - " на управляющий синий провод.
.....Значит нужно копать в контроллере. Подскажите что можно еще сделать!
Да не за что, как говорится чем могу... Ещё раз внимательно пройдитесь тестером, минусовой щуп на верхний по фото вывод электролита, ближайшего к транзистору, затем плюсовым щупом пощупайте на всех положительных выводах электролитов (до и после микры регулятора) Есть подозрение что-то там не слава богу... Также проверьте защитные резисторы малых сопротивлений в цепях питания, если таковые обнаружатся. К сожалению у меня нет перед глазами живого девайса а то бы разговор был более предметный. Не уверен что питание микроконтроллера должно быть +5, может оказаться и 3.3, лучше спросить у разработчика. Сначала убедитесь что питание везде норма, затем проверьте путь упомянутого синего провода и все вытекающие оттуда выводы.
Удачи.

Последний раз редактировалось Alex Handy; 21.11.2013 в 09:48. Причина: дополнение
Ответить с цитированием
  #39  
Старый 23.11.2013, 13:37
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Цитата:
Сообщение от Admin Посмотреть сообщение
Считать от точки против часовой стрелки. Микроконтроллер, это самая большая микросхема на плате.
Доброго времени суток! Проверил напряжение на микроконтроллере:



В первом случае на выходе 1,18V а при подключении синего провода падает до 0,18V. Во втором случае на выходе 0 и при подключении синего провода тоже 0.
На танталовых конденсаторах: на большом на взоде 0,01v и при подключении синего провода не меняется, на выходе 0. На маленьких - на выходах 0, на входах на одном 0,25, на другом - 0,65, при подключении синего провода падает на обоих ровно на 0,20v
Ответить с цитированием
  #40  
Старый 23.11.2013, 13:47
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Цитата:
Сообщение от Alex Handy Посмотреть сообщение
Да не за что, как говорится чем могу... Ещё раз внимательно пройдитесь тестером, минусовой щуп на верхний по фото вывод электролита, ближайшего к транзистору, затем плюсовым щупом пощупайте на всех положительных выводах электролитов (до и после микры регулятора) Есть подозрение что-то там не слава богу... Также проверьте защитные резисторы малых сопротивлений в цепях питания, если таковые обнаружатся. К сожалению у меня нет перед глазами живого девайса а то бы разговор был более предметный. Не уверен что питание микроконтроллера должно быть +5, может оказаться и 3.3, лучше спросить у разработчика. Сначала убедитесь что питание везде норма, затем проверьте путь упомянутого синего провода и все вытекающие оттуда выводы.
Удачи.
К сожалению моих знаний мат части не хватает, даже чтобы понять о чем идет речь(( Могу только догадаться как выглядит SMD транзистор с 3 ногами, ну и резистор тоже пойму, если не сложно напишите какого цвета и какая по счету нога и т.п. Синий провод на плате имеет 3 дорожки, и на каждой подходит к резистору и дальше уже не прозванивается..
Ответить с цитированием
  #41  
Старый 23.11.2013, 23:23
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Проблема или в неисправном транзисторе, или отсутствии постоянного питания 12 вольт на транзисторе. Питание та транзистор проходит через резистор 510 (51 Ом), и диод (красного цвета).
Ответить с цитированием
  #42  
Старый 23.11.2013, 23:49
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Цитата:
Сообщение от Admin Посмотреть сообщение
Проблема или в неисправном транзисторе, или отсутствии постоянного питания 12 вольт на транзисторе. Питание та транзистор проходит через резистор 510 (51 Ом), и диод (красного цвета).
Попробовал поверить все резисторы, 510 4 штуки, все рабочие, красных диода три, все в норме. А вот резистор, про который я писал в #24 посте, проверить не удалось, на дисплее мультиметра как была 1, так и не поменялась. Возможно я его перегрел, когда перепаивал в гараже. Подскажите его номинал и можно ли его заменить обычным резистором, не SMDшным?
Ответить с цитированием
  #43  
Старый 24.11.2013, 00:59
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

У вас схема не запитывается, нужно не мерять сопротивления элементов, а вольтметром проследить цепь питания. Как писал выше.
Ответить с цитированием
  #44  
Старый 24.11.2013, 12:21
Alex Handy Alex Handy вне форума
Пользователь
 
Регистрация: 09.09.2013
Адрес: Кана-чикова дача
Сообщений: 38
По умолчанию

Ну вот хороший повод учить мат. часть если есть желание разобраться самостоятельно. Либо поручить дело кому-то кто дружит с паяльником. Всё достаточно просто. Перечитайте внимательно предыдущие посты.
Удачи, мы верим в ваши способности!
Ответить с цитированием
  #45  
Старый 25.11.2013, 23:41
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Что-то ничего не выходит( Помощи попросить больше не у кого, т.к. никто из знакомых паяльник и в руки-то не берет. Совсем запутался, разными щупами показывает разное напряжение. Если не затруднит, подскажите по порядку, каким щупом замерять, второй щуп при этом на массу или на + вешать? Мат часть уже некогда учить, холода начались, подогреватель уже просто необходим!!!
Ответить с цитированием
  #46  
Старый 26.11.2013, 00:41
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Чёрный щуп на минус, красным измерять. Не забудьте подать питание на разём контроллера и синий провод прикрутить к минусу.
Ответить с цитированием
  #47  
Старый 28.11.2013, 21:24
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию



Попробвал, получается, что на 2х нижних ногах транзистора по 11,4V а на верхней 0,01. При подключении синего провода ничего не меняется, зато на ноге, отмеченной на рисунке напряжение падает до 0,71V. Значит в транзисторе дело? Какая у него маркировка?
Ответить с цитированием
  #48  
Старый 28.11.2013, 22:33
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Ну вот причину и нашли. Транзистор BC807.
Ответить с цитированием
  #49  
Старый 29.11.2013, 19:53
Kent-rzn Kent-rzn вне форума
Новичок
 
Регистрация: 30.10.2013
Адрес: Россия г. Рязань
Сообщений: 21
По умолчанию

Благодарю за помощь!! Всё получилось, сегодня запустил котел!! Ехать за транзистором было некогда, пипаял с платы от старого принтера подобный и все заработало! Единственное только что котел работает пару минут и выключается. Грешу на то, что не работает водяная помпа. Диагностика неисправность не показывает. А климат-контроль через какое время должен включиться в режим HE?
Ответить с цитированием
  #50  
Старый 29.11.2013, 21:57
Admin Admin вне форума
Администратор
 
Регистрация: 04.08.2013
Адрес: UA, Kiev-Odessa
Сообщений: 1,322
Отправить сообщение для Admin с помощью ICQ Отправить сообщение для Admin с помощью Skype™
По умолчанию

Ура, заработало!!!
Подключите VAG диагностику, и смотрите температуру жидкости в котле. Если температура быстро растёт до 80 градусов, значит циркуляционный насос не работает.
Лично я уже привык, что когда приезжает тачка на апгрейд котла до предпусковика, оказывается, что помпа не работает. Хотя на функцию догрева по ощущениям неработоспособность помпы не влияет.
Ответить с цитированием
Ответ

Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.


Текущее время: 11:45. Часовой пояс GMT +3.

Нажмите здесь, если заметили неисправности сайта, или сообщите о спамер-аккаунтах, для их блокирования.

Copyright 2000-2017, Pugachov Sergiy       Внимание! Использование любых материалов моего сайта разрешаю только при условии указания ссылки на эту страницу.